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There are three different general methods for creating models in Maya.  Each has its own
strengths and weaknesses.  A basic description of each is listed below:

Note:  Much of this information is taken directly from the Maya help menu, which is a
very good resource for any and all questions.

Polygons are n-sided shapes, defined by their corners (vertices) and the straight lines
between them (edges).  When modeling with polygons, triangles or quadrilaterals
("quads") are typically used, although Maya supports polygons with more sides.  An
individual polygon is often called a face and is the filled area defined by its vertices and
edges.

NURBS stands for Non-Uniform Rational B-Splines.  Non-Uniform refers to the
parameterization of the curve. Non-Uniform curves allow, among other things, the
presence of multi-knots, which are needed to represent Bezier Curves.  Rational refers to
the underlying mathematical representation. This property allows NURBS to represent
exact conics (such as parabolic curves, circles, and ellipses) in addition to free-form
curves.  B-splines are piecewise polynomial curves that have a parametric representation.

Subdivision Surfaces get their name from the process of being divided into regions of
greater detail.  You start with a base mesh and divide and subdivide regions into finer and
finer detail, with each subdivision giving greater control in that particular area.

Image Planes
Images may be imported into Maya and either be used as a background and/or
environment, but they can also be used as a template for creating curves and surfaces.
These image planes can either be attached to a camera or fixed.  If the image plane is
attached to a camera, the image follows all of the camera’s movements, whereas if the
image was fixed it would operate autonomously from the camera’s movements.

Importing an Image Plane:
1. Depending upon which view you would like the image plane inserted into,

select that view by clicking within its panel
2. In the Panel Menu, select View > Image Plane > Import Image
3. Browse to find the location of the image to be inserted
4. The image is inserted into the scene with the programs default attributes

associated with it.

Editing an Image Plane’s Attributes:



Verillium  |  MAYA Tutorial  |  NURBS

1. Select the view that the image plane was inserted into by clicking within its
panel

2. In the Panel Menu, select View > Image Plane > Image Plane Attributes
3. Select the name of the desired Image Plane
4. The Image Plane Attribute Editor opens.  Within this window the user can

modify a variety of different attributes associated with the image plane.
Attributes such as size, location, position…

Curves
A NURBS curve (Bezier curve) is made up of at least four Control Points (CVs) that
control the shape of the curve.  CVs determine how the curve is “pulled” from a straight
line between Edit Points.  Lines between consecutive CVs are called Hulls.  CVs are drawn
differently from each other in order to distinguish the start and the end of a curve. The
first CV (at the start point of the curve) is drawn as a box. The second CV is drawn as a
small "U".  All other CVs are drawn as small dots.

A NURBS curve’s geometry is determined by its degree.  Degree is the curve’s degree of
freedom to bend. A degree 1 curve connects its edit points with straight lines. A degree 2
curve can have one bend between edit points, and so on.  The default degree in Maya is 3,
which has four CVs for the first curve span. This is sufficient for almost any modeling
task.
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Creating a NURBS Curve:
1. Under the Main Menu, click Create > CV Curve Tool (Options Dialog Box)
2. Under Curve Degree select 3 Cubic
3. Under Knot Spacing select Uniform and Multiple End Knots
4. When there is a doubt as to whether the settings are correct, click Edit > Reset

Tool in the Options Dialog Box

Editing Curves
While modeling, it may become necessary to increase or decrease the amount of CVs on
a line in order to increase or decrease the precision of a line.  This is accomplished by
rebuilding the curve.  Before the curve can be rebuilt one must know the amount of CVs
currently populating the curve.  To do this, select the curve and open the Attribute Editor
(Crtl+a).  Under NURBS Curve History Drop Down Menu and within the section titled
Spans is the number of CVs that currently make up the line.

Rebuilding a Curve:
1. With the Modeling Pull Down Menu selected in the Status Line, click Edit Curve

> Rebuild Curve (Options Dialog Box) in the Main Menu
2. Rebuild Type are the different ways in which a curve may be rebuilt.  Uniform

(most commonly selected) rebuilds a curve with uniform parameterization,
meaning, the curve’s CVs are distributed evenly over the length of the curve.
With this selected one can change the amount of CVs on a particular curve and
the degree of that curve

3. Set the Parameter Range to 0 to 1
4. Set the Number of Spans and the Degree to a value of the user’s choosing.
5. Click Rebuild to complete

Rebuilding a Curve allows the user to increase or decrease the precision of a curve
uniformly along the length of that curve.  In order to be more accurate in the placement
of additional CVs the user would use the Insert Knot command.  Insert knot places an edit
point (and in turn a CV) at a selected point on the curve.

Inserting a Knot:
1. In Object Mode, select the curve
2. In Component Mode, make sure that only Select by component type: Parm

Points is selected
3. Click at the location on the curve where the additional Edit Point (in turn CV) is

required
4. With the Modeling Pull Down Menu selected in the Status Line, click Edit Curve

> Insert Knot (Options Dialog Box) in the Main Menu
5. Insert Location is to be set to At Selection, and the Multiplicity Value is to be set

to 1
6. Click Insert to complete
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A curve may need to be broken up into segments, and in order to accomplish this one
would utilize the Detach Curve Tool.  This will split a curve into a series of separate
curves depending upon how many points you select on the curve.

Detaching a Curve:
1. In Object Mode, select the curve
2. In Component Mode, make sure that only Select by component type: Parm

Points is selected
3. Click at the location on the curve where it is to be split
4. With the Modeling Pull Down Menu selected in the Status Line, click Edit Curve

> Detach Curve (Options Dialog Box) from the Main Menu
5. Click Detach to complete

Curves that intersect may be cut into individual segments using the Cut Curves Tool.  Cut
Curves splits curves wherever they cross each other in a particular view.

Cutting a Curve:
1. Determine in which view the curves are intersecting each other in, select that

view by clicking within its Panel
2. In Object Mode, select each of the intersecting curves
3. With the Modeling Pull Down Menu selected in the Status Line, click Edit Curve

> Cut Curve (Options Dialog Box) in the Main Menu
4. Find Intersections is to be set to In 2D and 3D
5. Cut is set depending upon if the user wishes both curves to be cut (At all

Intersections) or only the first curve that was selected (Using Last Curve).
6. Keep is most commonly set to All Curve Segments
7. Use Tolerance is set to Global
8. Click Cut to complete

In order to open a closed curve or close an opened curve, one must use the Open/Close
Curve Tool.  The Open/Close Curve Tool converts a curve between open and closed.

Opening or Closing a Curve:
1. In Object Mode, select the curve to be opened or closed
2. With the Modeling Pull Down Menu selected in the Status Line, click Edit Curve

> Open/Close Curve (Options Dialog Box) in the Main Menu.
3. The Shape value determines the ultimate geometry of the curve.  Ignore does

not preserve the shape of the original curve.  Preserve adds or deletes control
vertices as necessary to preserve the shape of the original curve. This is the
default setting.  Blend tries to create continuity on the resulting curve. It uses
the Blend Bias for the amount of smoothing

4. Check Insert Knot if you wish a knot to be inserted at the join point.  With this
selected, the user may set a value for the Insert Parameter. This option is
available only if you select Blend.  The Insert Parameter sets the amount of
influence the inserted knot has on the curve shape.

5. Click Open/Close to complete

Multiple line segments have the ability to be joined together to form one continuous
curve.  The Attach Curve Tool joins curves at their endpoints to form a new curve.

Attaching Curves:
1. In Object Mode, select the curves that are to be attached
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2. With the Modeling Pull Down Menu selected in the Status Line, click Edit Curve
> Attach Curve (Options Dialog Box) from the Main Menu

3. The Attach Method is set depending upon whether the user wishes the curves
to have minimal curvature smoothing at the join point (Connect) or to have a
smooth curvature at the join point (Blend)

4. The Blend Bias (only available if Blend is selected as the Attach Method)
modifies the amount of Blending.

5. With Insert Knot selected (only available if Blend is selected as the Attach
Method) the user will more closely match the curvature of the original curves

6. The Insert Parameter adjusts the positioning of the knots added when the Insert
Knot variable is activated

7. Click Attach to complete

When lofting, the direction of the curves that are being used is crucial to the success of
the loft.  In order to achieve a continuously smooth loft, each of the curves selected must
be oriented in the same direction.  Reverse Curve Direction reverses the direction of
selected curves.

Reversing the Direction of a Curve:
1. In Object Mode, select the curves that are to be attached
2. With the Modeling Pull Down Menu selected in the Status Line, click Edit Curve

> Reverse Curve Direction (Options Dialog Box) from the Main Menu
3. Click Reverse to complete

In order to modify the shape of a surface it is best to extract the curves that make up that
surface and modify those rather than the surface itself.  This is because the curves make
up the shape of the surface and not the other way around.  Also, at times, a single
isoparm from a surface may require duplication so it may be used as a curve.  Duplicate
Surface Curves creates a new NURBS curve from the selected surface edge, isoparm, or
curve-on-surface.

Duplicating a Surface Curve or a Series of Surface Curves:
1. In Object Mode, select the surface from which to extract isoparms
2. In Component Mode, make sure that only Select by component type: Isoparm

is selected
3. Select all isoparms that are to be duplicated
4. With the Modeling Pull Down Menu selected in the Status Line, click Edit Curve

> Duplicate Surface Curves (Options Dialog Box) from the Main Menu
5. Click Duplicate to complete

Duplicating All of the Isoparms of a Surface in a Particular Direction:
1. In Object Mode, select the surface from which to extract isoparms
2. With the Modeling Pull Down Menu selected in the Status Line, click Edit Curve

> Duplicate Surface Curves (Options Dialog Box) from the Main Menu
3. Visible Surface Isoparms allows the user to define which (U, V, or Both)

direction of isoparms they would like to have duplicated
4. Click Duplicate to complete

Surfaces
Curves cannot be rendered; only surfaces can.  In modeling, curves are created to aid in
the construction of surfaces.  A surface is an area in 3D space defined by the
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parameterization of two variables, U and V.  It is important to understand the distinction
between UV coordinate system and the XYZ world space coordinates.  The latter system
identifies any point in Maya’s 3D world space, whereas the former deals only with a 2D
surface area.

Lofting is the most often used tool in surface modeling.  The Loft Tool creates a surface
using selected curves, isoparms, or trimmed edges.  The settings for the Loft Tool are
simple, and the default settings need not be changed for most occasions.  The order that
curves are selected for lofting is critical to the success of the surface.  The first curve
selected determines the U direction of the lofted surface, and since the surface is lofted in
the same order the curves are selected, the sequence in which you select the curves is
important.

If the curves being lofted are uniform curves and have the same number of spans, then
the resulting lofted surface will retain the same uniform parameterization and the same
number of U spans as the curves that make up the surface.  If the curve spans are
different, you will generally end up with a surface that has many more U spans.  The
number of V spans of the surface will equal the number of the curves being lofted minus
1, assuming the default settings are being used.

Creating a Lofted Surface:
1. In Object Mode, Shift select all curves, one at a time, that are to be used to make

up the lofted surface
2. With the Modeling Pull Down Menu selected in the Status Line, click Surfaces >

Loft (Options Dialog Box) in the Main Menu
3. If Auto Reverse is off, the curves are used as they are which may result in a

twisted surface. If on, the curves are automatically reversed so that they are
each in the same direction, resulting in a smooth loft.  Close determines
whether or not the surface is a closed or open surface

4. Surface Degree should be set to Cubic (unless a Linear [faceted] surface is
desired)

5. Click Loft to complete

The Revolve tool on the Surfaces menu takes selected curves and revolves them around a
designated axis, which you set in the Options Dialog Box, from the center-pivot of that
curve.  The profile curve can be a curve, curve-on-surface, surface isoparm, or trim edge.
In other software packages this tool is known as lathe.

Creating a Revolved Surface:
1. In Object Mode, select the profile curve that is to be revolved into a surface
2. With the Modeling Pull Down Menu selected in the Status Line, click Surfaces >

Revolve (Options Dialog Box) in the Main Menu
3. Axis Preset should be set to whichever axis the profile is to be revolved about
4. Surface Degree should be set to Cubic (unless a Linear [faceted] surface is

desired)
5. Start Sweep Angle determines where the surface is to begin and End Sweep

Angle determines how far in a complete revolution the surface will go
6. The Segments value determines how many sections are used to create the

surface of revolution. With a sweep of 360 degrees, six or eight sections are
usually sufficient.

7. Click Revolve to complete
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The Extrude tool extrudes a surface from selected curves, or curves on a surface, or
isoparms.  Extruding typically involves two or more curves, or curves on a surface, or
even isoparms.  The first curves selected are the Profile curves that will be extruded, and
the last curve selected is the Rail curve that will guide the extrusion.

Creating an Extrusion:
1. In Object Mode, shift select the Profile curve(s) (the curve[s] that is to be

extruded)
2. With the Modeling Pull Down Menu selected in the Status Line, click Surface >

Extrude (Options Dialog Box) from the Main Menu
3. Style > Distance setting requires only one curve, and it activates the Extrude

Length Slider.  Style > Flat setting lets the Profile curve maintain its own
orientation as it moves along the Path curve.  Style > Tube setting makes the
Profile curve turn with the Path curve (this is the default and most commonly
used Style setting)

4. Result Position > At Profile forces the Path curve to come to the Profile curve to
complete the extrusion.  Result Position > At Path forces the Profile curve to
come to the Path curve to complete the extrusion (this is the most commonly
used Result Position)

5. Rotation rotates the profile curve as it is extruded along the path curve. Higher
values cause the surface to stray from the path, especially with scaling

6. Scale scales the profile curve as it is extruded along the path curve. Higher
values cause the surface to stray from the path, especially with rotation

7. Click Extrude to complete

When two curves are lofted, the result is a four sided surface, two of whose opposing
edges are defined by the curves.  The other two edges are automatically calculated.  The
Boundary tool, in contrast, enables the four sides of a surface to be created from four
curves, thus giving more control over how all four edges are defined.  In order for this
tool to work, each end of a curve needs to intersect with another curve.

Creating a Boundary Surface:
1. In Object Mode, shift select the curves that are to make up the Boundry surface
2. With the Modeling Pull Down Menu selected in the Status Line, click Surface >

Boundary (Options Dialog Box) from the Main Menu
3. Curve Ordering > Automatic creates the Boundary surface with an internal

decision process.  Curve Ordering > As Selected causes the curve selection
order to determine the resulting surface.

4. The Common End Points options let you decide whether the end points should
match before the Boundary surface is created.  If you select Optional, the
surface is created even if the ends of the curves don't match. This is the default.
If you select Required, the Boundary surface is only built if the end points of the
curves match exactly.

5. Click Boundary to complete

Birails extrude one or more Profile curves along two Rail curves.  The Parameters of the
Profile curve determine the V parameters of the surface while the two Rail curves define
the U parameters of the surface.  There are three main options within the Birail tool.
Birail 1 allows the user to select one Profile curve to make up the surface.  Birail 2 allows
the user to select two Profile curves to make up the surface.  Birail 3+ allows the user to
select three or more Profile curves to make up the surface.
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1. With the Modeling Pull Down Menu selected in the Status Line, click Surface >
Birail 1 or Birail 2 or Birail 3+ (Options Dialog Box) from the Main Menu

2. Depending upon which Birail Tool the user is going to utilize, in Object Mode,
shift select the Profile curve(s) and then the two Rail curves

3. For Transform Controls, Select Proportional or Non Proportional to choose
how to scale the profile curve sweep along the rails.

4. Click Birail to complete

Editing Surfaces
Once a surface is created, they will often need to be manipulated to produce the final
form.  Maya’s many surface editing tools generally behave in the same manner as their
curve counterparts.

Detach Surfaces splits a surface into multiple surfaces at the selected isoparms.

Detaching a Surface:
1. In Object Mode, select the surface that is to be detached
2. In Component Mode, make sure that only Select by component type: Isoparm

is selected
3. Select the isoparm at which the surface is to be split.  Multiple isoparms can be

selected in order to split the surface into multiple parts.
4. With the Modeling Pull Down Menu selected in the Status Line, click Edit

Nurbs > Detach Surfaces (Options Dialog Box) from the Main Menu
5. Click Detach to complete

Attach Surfaces joins two surfaces together into a single surface.

Attaching Two Surfaces:
1. In Object Mode, select the surfaces that are to be attached
2. In Component Mode, make sure that only Select by component type: Isoparm

is selected
3. Select an isoparm on each surface where the user wants the surfaces to be

joined
4. With the Modeling Pull Down Menu selected in the Status Line, click Edit

Nurbs > Attach Surfaces (Options Dialog Box) from the Main Menu.  This will
move the surfaces together and join them.  In order to fill the area between the
two surfaces with new surface area select Edit Nurbs > Attach Surfaces Without
Moving

5. Click Attach to complete

Rebuilding Surfaces allows the user to alter the number of isoparms that make up a
surface in either the U or V direction.  In order to determine which direction is which,
select the surface in Object Mode and transfer into Component mode.  With Select by
component type: Points selected, find the starting point of the surface.  This is identified
by the open square Point.  The next Point adjacent to the starting Point is identified with
either a U or a V.  This tells you which direction the surface is running.

Rebuilding a Surface:
1. In Object Mode, select the surface that is to be Rebuilt
2. Open the Attribute Editor by either hitting Crtl+a or Window > Attribute

Editor
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3. Within the category Spans UV there are two numbers (a).  These numbers
corresponds to the amounts of Spans in the U and V direction that the surface
currently has.  Keep this window open for reference

4. With the Modeling Pull Down Menu selected in the Status Line, click Edit
Nurbs > Rebuild Surfaces (Options Dialog Box) from the Main Menu.

5. Modify the number of U Spans and/or V Spans to the desired amount
6. Make sure that Degree U and Degree V are both set to 3 Cubic (unless a Linear

[faceted] surface is desired)
7. Click Rebuild to complete

(a)  

Curves on Surfaces are defined by Maya as being curves that are mapped to the UV
parameters of the surface they are on, rather than the XYZ coordinates of world space.
Maya allows the user to project curves, curves on surfaces, isoparms, or trimmed edges to
a designated surface and create curves on that surface.

There are two ways in which a curve on surface can be drawn.  The first to actually draw
the curve onto the surface and the other is to project a curve that is removed from the
surface onto the surface.

Draw a Curve-On-Surface:
1. In Object Mode, select the surface on which the curve-on-surface is to be

drawn.
2. In the Status Line, click the "Make the selected object live" icon (a).  This allows

the user to draw directly onto the surface
3. Choose Create > CV Curve Tool
4. Draw a curve on the live surface.
5. When the curve is finished, click the "Make selected object live" icon (a) again to

deactivate the snap.

(a)  

Project a Curve Onto a Surface Along the View Direction:
1. In Object Mode, shift select a surface and one or more curves
2. Select the objects in a View Panel pointing in the direction you want to project.

For example, if you want to project along the Z-axis, select the objects in the
Top view

3. With the Modeling Pull Down Menu selected in the Status Line, click Edit
NURBS > Project Curve on Surface (Options Dialog Box)

4. Set Project Along to Active View
5. Click Project to complete
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Trimming a surface removes (actually hides) any part of a surface bounded by curves-on-
surface. This lets you create complex edges and holes in NURBS surfaces. You must
create curves-on-surface before you can trim the surface.

Trimming a Surface:
1. With the Modeling Pull Down Menu selected in the Status Line, click Edit

NURBS > Trim Tool
2. Select the surface that is to be trimmed
3. A "trim grid" appears on the surface
4. Click the regions (defined by curves-on-surface) of the surface you want to keep

(you do not need to hold Shift to click multiple regions)
5. As you click, regions that will be trimmed away are dotted, and regions that

will be kept are solid
6. If you want to change the tool so you click the parts of the surface you want to

trim off, open the Trim Tool Options Dialog and set Selected State to Discard
7. Click to Trim to complete

Untrim a Trimmed Surface:
1. In Object Mode, select the surface or surfaces that are to be untrimmed
2. With the Modeling Pull Down Menu selected in the Status Line, click Edit

NURBS > Untrim Surfaces
3. The default is to remove all trims from the surface, restoring it to its original

state. To only reverse the most recent trim operation, open the Untrim Surfaces
Option Dialog Box and set Untrim to Last.

4. Click Untrim to complete

Snapping
The Snapping tools allow the user to transform an object or a component of an object to
snap to grids, curves, points, or a surface.  These elements become targets, or magnets,
when activated.  These tools can be accessed the Status Line (a) of the UI or they can be
accessed via Maya’s Hotkeys:

Press X and click or drag to snap to a grid
Press C and click or drag to snap to a curve
Press V and click or drag to snap to a point

(a)  


